[호스트 이름 설정하기]
명령 형식
- Router(config) # hostname [호스트 이름]
e.g.) 라우터의 이름을 R1으로 변경하시오
- Router(config) # hostname R1
[접속 메시지 설정하기]
명령형식
- Router(config) # banner motd #
Enter TEXT message. End with the character '#'.
[접속 메시지] #
e.g.) 콘솔 또는 텔넷 접속 시 "I'm Router" 메시지가 보이도록 설정하시오.
- Router(config) # banner motd #
Enter TEXT message. End with the Character '#".
I'm Router #
[명령어 히스토리(History) 설정하기]
명령형식
- 콘솔/텔넷 설정 중에는
Router(config-line) # history size [명령개수]
- 프리빌리지 모드에서는
Router # terminal history size [명령개수]
e.g.) 사용자가 최근에 사용한 10개의 명령어만 기억하도록 설정하시오.
- 콘솔 / 텔넷 설정 중에는
Router(config-line) # history size 10
- 프리빌리지 모드에서는
Router # terminal history size 10
[DNS 설정]
명령형식
- Router(config) # ip host [문자주소] [IP주소]
e.g.) Router에서 ping 테스트 시 IP 주소 이외 s1의 호스트 이름(소문자)으로 ping 테스트가 가능하도록 하시오.
(s1의 IP 주소는 192.168.50.100 일 때)
- Router(config) # ip host s1 192.168.50.100
[DNS 질의 금지 설정(시스템 홀딩 방지)]
명령형식
- Router(config) # no ip domain-lookup
e.g.) 잘못된 명령을 내렸을 시 DNS 질의하지 않도록 하시오.
- Router(config) # no ip domain-lookup
[Privilege Mode 접속을 위한 암호 설정]
명령형식
- Router(config) # enable password [패스워드]
e.g.) 'Privileged Mode'에 접속하기 위하여 'qwe123!@#'라는 암호를 부여하시오.
- Router(config) # enable password qwe123!@#
[암호저장방식(MD5) 설정]
명령형식
- Router(config) # enable secret [패스워드]
e.g.) R1에서 Privileged Mode에 접속하기 위해 'qwe123!@#' 암호를 입력하도록 하시오.
단, 암호는 MD5 방식으로 저장되도록 하시오.
- Router(config) # enable secret qwe123!@#
[패스워드 부여 콘솔 로그인(Console Password)]
명령형식
ㅇ 콘솔 설정
- Router(config) # line console 0
ㅇ 패스워드 부여
- Router(config-line) # password [패스워드]
ㅇ 콘솔 접속
- Router(config-line) # login
e.g.) Router에 콘솔 접속 시 'qwe123!@#' 암호를 이용하여 로그인하도록 하시오.
- Router(config) # line console 0
- Router(config-line) # password qwe123!@#
- Router(config-line) # login
* 만약 라우터에 부여된 모든 암호를 MD5 방식으로 암호화하라고 한다면
- Router(config) # service password-encryption
[원격로그인 - Telnet 및 Password 설정]
명령형식
ㅇ 텔넷 사용자 ID 및 암호 설정
- Router(config) # username [사용자ID] password [패스워드]
ㅇ 텔넷 및 텔넷 접속자 수 정의
- Router(config-line) # line vty 0 [사용자수-1]
ㅇ 텔넷 접속
- Router(config-line) # login [local]
e.g.) Router에 텔넷 접속 시 'test' 사용자로 로그인하도록 구성하시오. (암호 : 'qwe123!@#')
- Router(config) # username test password qwe123!@#
- Router(config) # line vty 0 4
- Router(config) # login local
* 만약 암호 인증 후에 바로 'Privileged mode'에 접속되게 하려면
- Router(config) # username test privilege 15 password qwe123!@#
위와 같이 사용자 아이디와 패스워드 사이에 'privilege 15'를 넣어준다.
[텔넷 등을 사용할 때 사용자 입력이 일정시간 없을 때 세션 종료 설정]
명령형식
- Router(config-line) # exec-timeout [분 초]
e.g.) 접속 후 1분 30초간 입력이 없으면 세션이 종료되도록 하시오.
- Router(config-line) # exec-timeout 1 30
[로컬 사용자 로그인 인증]
명령형식
- Router(config) # username [사용자ID] password [패스워드]
- Router(config) # line console 0 (혹은 vty 0 4)
- Router(config-line) # login local
e.g.) 콘솔을 통하여 연결할 경우 'admin' 사용자로 로그인하도록 구성하시오. (암호 : 'qwe123!@#')
- Router(config) # username admin password qwe123!@#
- Router(config) # line console 0
- Router(config-line) # login local
[인터페이스의 활성화와 IP 주소부여]
명령형식
- Router(config) # interface [포트 ID]
- Router(config-if) # no shutdown
- Router(config-if) # ip address [IP 주소][Subnet Mask]
e.g.) 라우터의 fa0/0 포트에 IP 주소(192.168.50.100/16)를 부여하고 활성화하시오.
- Router(config) # interface fa0/0
- Router(config-if) # no shutdown
- Router(config-if) # ip address 192.168.50.100 255.255.0.0
[TFTP 백업]
명령형식 - startup-coinfig 파일을 저장
- Router # copy startup-config tftp
- Address or name of remote host[]? [TFTP 서버 주소]
- Destination filename [R1-config]? [저장할 파일명]
명령형식 - running-config 파일을 저장
- Router # copy running-config tftp
- Address or name of remote host[]? [TFTP 서버 주소]
- Destination filename []? [저장할 파일명]
e.g.) Router의 startup-config 파일과 running-config 파일을 TFTP 서버(IP: 192.168.50.100)로 저장하시오.
(각각의 저장될 파일명: R1_config/ISP_config)
- Router # copy startup-config tftp
- Address or name of remote host[]? 192.168.50.100
- Destination filename []? R1-config
- Router # copy running-config tftp
- Address or name of remote host[]? 192.168.50.100
- Destination filename []? ISP_config
명령형식 - IOS 파일(파일명 지정)을 저장
- Router # copy flash tftp
- Source filename []? [복사할 파일명 입력]
- Address or name of remote host[]? [TFTP 서버 주소]
- Destination filename []? [저장할 파일명]
e.g.) 라우터의 IOS(c2800nm-advipservicesk9-mz.124-15.T1.bin)를 TFTP 서버(IP: 192.168.50.100)에 백업하시오.
- Router # show flash
- Router # copy flash tftp
- Source filename c2800nm-advipservicesk9-mz.124-15.T1.bin
- Address or name of remote host 192.168.50.100
- Destination filename c2800nm-advipservicesk9-mz.124-15.T1.bin
[DCE-DTE 구성(라우터와 라우터끼리 연결된 경우 시계표시가 붙은 라우터의 해당 포트에서 설정함)]
명령형식
- Router(config) # clock rate [주어진 클럭 펄스값]
e.g.) R0과 ISP 라우터 사이의 Clock Rate 값은 56000을 사용하시오.
- R0(config) # interface s0/0/0
- R0(config-if) # clock rate 56000
- R0(config-if) # no shut
[Inter-VLAN 설정(인터페이스 활성화 후 설정함)]
명령형식 - Sub-Interface 설정
- Router(config) # interface [서브인터페이스 ID]
명령형식 - 표준 프로토콜 802.1q 적용
- Router(config-subif) # encapsulation dot1Q [VLAN ID]
- Router(config-subif) # ip address [해당 네트워크 게이트웨이 주소]
e.g.) Router의 fa0/0 포트에 서브 인터페이스를 구성하시오. 서브 인터페이스의 이름은 각 VLAN ID 값을 사용하고, 아래의 표를 참고하여 IP 주소를 설정하시오.
네트워크 | 호스트[장치명] | IP 주소 | Subnet Mask |
192.168.100.0/25 (VLAN 10) |
Router [fa0/0.10] | 192.168.100.126 | 255.255.255.128 |
192.168.100.128/25 (VLAN 20) |
Router [fa0/0.10] | 192.168.100.254 | 255.255.255.128 |
- Router(config) # int fa0/0
- Router(config-if) # no shut
- Router(config-if) # int fa0/0.10
- Router(config-subif) # encapsulation dot1Q 10
- Router(config-subif) # ip address 192.168.100.126 255.255.255.128
- Router(config-subif) # int fa0.0/20
- Router(config-subif) # encapsulation dot1Q 20
- Router(config-subif) # ip address 192.168.100.254 255.255.255.128
'정보기기운용기능사' 카테고리의 다른 글
[정보기기운용기능사] 2016년도 상시 기능사 25회 실기 합격 후기 (0) | 2022.07.29 |
---|---|
[정보기기운용기능사] 2016년도 상시 기능사 19회 필기 합격 후기 (0) | 2022.07.28 |